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Ex.No. 

1 

Raster Analysis (Data Properties, Map Algebra 

Reclassification) 

Date  

 

Aim: 

To perform raster analysis such as checking raster properties, mosaic analysis, and reclassification. 

Software: 

ArcMap 10.2.2 

Procedure: 

 Create a folder with your roll number as name. 

 Copy Spatial93 folder from share folder 

 Create a folder named "EX-1" and a subfolder named "SCRATCH" under the folder "EX-1". 

 Open the ArcMap software 10.2.2 

 Add Data -> Spatial93-> Elevation, Landuse 

 Set the environment settings:  

o Workspace folder  for Current & Scratch for scratch ws. 

o Raster Analysis Cell size: Select same as layer elevation. 

o Check raster, workspace, cell size 

Environment settings  

Add data -> Spatial 93 Elevation 

 Geoprocessing -> Environment -> workspace -> add ws for current working and scratch for 

scratch workspace 

 Raster Analysis -> cell size -> select same as data 

 Check OK 

Layer Properties 

 Right click  Elevation/Landuse layer -> Properties ->Note Extent, cell size, statistics, 

projection, rows & columns.  

 

Note the raster information (Elevation and Landuse) 

 No. of Columns and Rows:  

 Cell size (x,y)                :  

 Extent:  

 Top      :  

 Left      :  

 Right    :  

 Bottom :  

 Spatial Reference           :  

 Datum                            :      

 Statistics:  

 Min:   

 Max:   

 Std Dev:   

 Class:  

 Right click on dataset -> Properties 

 

Map Algebra:  

o Enable  Extension -> Spatial Analyst Extension 

o Enable  Spatial Analyst tool bar 

o Open the ArcToolbox -> Spatial Analyst Tools -> Raster Calculator 

o Raster Calculator:  select layesr and do arithmetic and logical operations  

o For the layer if required Stretch data to display  
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o Using Identify toolto find point details each pixel and note 

Raster Calculator 

 Extension -> Spatial Analyst Tools -> Raster Calculator 

 Input layer :Elevation 

 Enter the expression: "Elevation" – 50 

 Output file name : Elevation-50 

 Click OK 

Original elevation values will be modified to "Elevation-50" 

Using Identify tool find point details each pixel between the two elevation data  and note 

 

 

Reclassification 

 

 Binary Marking: Setting some threshold and classify 

 Regrouping: Grouping the values  

 Ranking: good, better, best 

 Scale changing  or Class Reduction (reducing the no. of classes) 

 

Reclassification can be carryout by changing symbology for just printing or by tool if required for 

data for further processing  

 Right click the layer -> properties, By changing symbology  we reclassify (classified, 

classified, under major values) Can also change no. of classes & classification method 

(manual, equal interval) 

  Another way ,ArcToolbox -> Spatial Analyst tool ->Reclassify -> Reclassify, we can save 

another file. 

 In Raster Calculator, we can also do Binary marking using logical condition 

 

Binary Masking (Map Algebra) 

 Spatial Analyst Tools -> ArcToolbox -> Map Algebra -> Raster Calculator 

 Input layer :Elevation 

 Enter the expression: : "Elevation" ≥ 1500  

 Output file name : binary_mask.tif 

 Click OK 

Original elevation values will be classified into 2 classes" 

 

Binary Masking (By Reclassify Tools) 

1. ArcToolbox -> Spatial Analyst Tools -> Reclassify -> Reclassify 

2. Input: Elevation 

3. Parameters: Reclass field: value 

4. Classes: 2 

5. Method: equal interval 

6. Output Raster: binary_mask1.tif 

Original elevation values will be classified into 2 classes" 

 

Class Reduction 

1. ArcToolbox -> Spatial Analyst Tools -> Reclassify -> Reclassify 

2. Input: Elevation 

3. Parameters: Reclass field: value 

4. Classes: 3 

5. Method: equal interval 

6. Output Raster: Class-Restriction.tif 
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Scale Changing 

 Right click layer -> Properties -> Symbology 

 Classes: 3  

o Low: 438 - 2393.333333 - suitable 

o Moderate: 2393.333333 - 3053.333333 - moderate 

o High: 3053.333333 - 4361 - non-suitable 

 Method: equal interval 

 

 

For every layer create a simple Layout : 

 At bottom we have data view and layout view 

 Insert -> Title, scale bar, north arrow 

 At bottom, insert north arrow, scale bar, and legend for threshold value 

 File -> Layout map to A4, save, and save in jpg format 
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Ex. No. 

2 

Raster Analysis (Arithmetic and Logical Overlay) and 

Surface Analysis (Slope, Aspect, Viewshed) 

Date  

 
Aim: 

To understand and perform DEM analysis (Elevation, Slope, Aspect) 

Software: 

ArcMap 10.2.2 

Procedure: 

o Create a folder EX2 under your roll number folder. 

o Create a ws and scratch folders under named "EX2"  

o Add layers to ArcMap from spatial93 folder (Elevation & Landuse) 

o Set the environment settings:  

o Workspace folder for current & scratch for scratch ws, Extent same as Landuse 

o settings Cell size: Same as the elevation 

o Slope: Slope gives the slope in the height levels 

o Aspect: Aspect gives the direction (degrees) 

o HillShade: Visualisation of the slope 

o Viewshed: Visible and invisible line of sight locations/regions 

 

Slope: 

Open ArctoolBox -> SpatialAnalyst tools->Surface->Slope  

Input raster        :elevation 

Output raster      :slope_elev 

Measurment       :degree 

Zfactor                :0.3048         ;(ft to m) 

 

 View and explore the slope layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 

 

Aspect: 

Open ArctoolBox -> SpatialAnalyst tools->Surface->Aspect  

Input raster        :elevation 

Output raster      : aspect_elev  

 

 View and explore the aspect layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 

 

Hillshade: 

Open ArctoolBox -> SpatialAnalyst tools->Surface->Hillshade 

 

Input raster        :elevation 

Output raster      :Hillshade 

Azimuth             : default 

Altitude:             : default 

Zfactor                :0.3048         ;(ft to m) 

 View and explore the hillshde layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 

 

 

Drape landuse over hillshade 
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We can view the landuse with a 3D like image by draping it over the hilldshade 

 In the table of content deselect all other layers except landuse and hillshade 

 Reorder the layers such that hillshade just below landuse 

 In the Effects toolbar adjust the transparency of landuse to 50%  

We can see the display landuse with hillshade effect 

 

 Prepare a simple layout and export as jpeg file 

 

Viewshed 

Gives the details about the line of sight / region from the given point 

 Add “School” vector point data 

 Using selection tool select one or few schools 

 

Open ArctoolBox -> SpatialAnalyst tools->Surface->Viewshed 

 

Input raster            :elevation 

Input point feature: school 

Output raster        :Viewshed 

Zfactor                 :0.3048         ;(ft to m) 

 

 View and explore the viewshed layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 

 

Overlay : 

Reclass_landuse  and slope each having tw classes of equal interval 

ArcToolbox -> Spatial Analyst Tools -> Reclassify -> Reclassify 

Input: Slope  

Method: Equal Interval 

No. of classes: 2/10 

Output: E:\Geo6\roll.no\EXI\SCRATCH\Reclass_slope.tif 

 

Input: Landuse 

Method: Equal Interval 

No. of classes: 2/10 

Output: E:\Geo6\roll.no\EXI\SCRATCH\Reclass_land.tif 

 

Logical Overlay: 

Spatial Analyst Tools -> Map Algebra -> Raster Calculator 

Input layer : Reclass_slope.tif, Reclass_land.tif 

Enter the expression: :  : Reclass_slope.tif & Reclass_land.tif 

Output file name : logical_over.tif 

 

 View and explore the logical_over layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 

 

 

 

 

 

Arithmetic Overlay: 
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Spatial Analyst Tools -> Map Algebra -> Raster Calculator 

Input layer : Reclass_slope.tif, Reclass_land.tif 

Enter the expression: :  : (Reclass_slope.tif *100)+ Reclass_land.tif 

Output file name Arith_over.tif 

 

 

 View and explore the Arith_over layer properties, legend etc. 

 Prepare a simple layout and export as jpeg file 
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Ex. No. 

3 

Raster Analysis (Distance, Weighted Overlay) Date  

 

Aim: To understand the weighted overlay and distance raster processing 

 

Problem definition  

Identify a new school site that fulfils the following criteria: 

 Should be near to the recreation sites 

 Away from the existing schools 

 Suitable land use 

 Plain terrain 

 Road connectivity. 

 

Software Used: 

ArcMap 10.2.2 

 

Procedure: 

o Create a folder EX3 under your roll number folder. 

o Create a ws and scratch folders under "EX3"  

o Open the ArcMap software 

o Add data from spatial93 folder (Landuse, Elevation, recreation sites and schools). 

o Set the environment settings:  

o Workspace folder for current & scratch for scratch ws, Extent same as Landuse 

o settings Cell size: Same as the elevation 

 

Slope 

For Plain terrain  

Open ArctoolBox -> SpatialAnalyst tools->Surface->Slope  

Input raster        :elevation 

Output raster      :slope_elev 

Measurment       :degree 

Zfactor                :0.3048         ;(ft to m) 

 

Near Analysis: Distance Raster 

Open ArctoolBox -> SpatialAnalyst tools->distance->Euclidian distance  

Input : rec_sites 

Output : rec_dist 

 

      View and explore the  rec_dist layer properties, legend etc 

 

Open ArctoolBox -> SpatialAnalyst tools->distance->Euclidian distance  

Input : school 

Output : sch_dist,  

 

View and explore the sch_dist layer properties, legend etc 
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Reclassify: 

To normalise reclassify the three layers slope_elev rec_dist and sch_dist 

Weighted Overlay needs discrete values so reclassification is needed 

Normalization: By converting all values into one scale. For this, reclassification is needed. 

 Here, all the three layers slope_elev rec_dist and sch_dist values in are different scales, so 

reclassification is needed to bring into the common scale. The scale range is 1 to 10. We will 

assign new required value class is 10 and unwanted class value is  1 

 Reclassify Input (slope) -> Method (equal) -> Slope:0-10 -> unwanted (0) 10+Required (1) 

o Instead of manually entering, we can use the Reverse the values option. 

 Reclassify Input (rec_distance) -> Output... Method (equal) -> 

o Required (closer sites) – so new value 10 

o we can use the Reverse the values option 

 Reclassify Input (sch_distance) -> Output... Method (equal) -> 

o Condition away: so last group belongs to 10 no need to reverse the values option. 

Reclass Slope: 

 Open ArctoolBox -> Spatial Analyst tools-> Reclassify -> Reclassify  

o Input Raster: slope_elev 

o Method: equal interval 

o Classes: 10  

 (our requirement is plain terrain, in slope analysis first group, i.e. 0-5° 

belongs to plain terrain, so we can fix it at 10 (plain terrain = 10). So using 

reverse option, we can numbers to nearest from 10 to 0) (plain to steep) = [10 

- 1] (reverse) 

o Output Raster: Reclass_slope 

 

View and explore the Reclass_slope layer properties, legend etc 

 

Reclass Rec distance 

 Open ArctoolBox -> Spatial Analyst tools-> Reclassify -> Reclassify  

o Input Raster: rec_dist 

o Method: Equal Interval 

o Classes: 10  

 Our requirement is nearest to recreation sites. So again fix 10 as number for 

nearest and 10 as farthest. 

 Click reverse option. 

o Output: Reclrec_dist 

View and explore the Reclrec_dist layer properties, legend etc 

 

Reclass School distance 

 Open ArctoolBox -> Spatial Analyst tools -> Raster -> Reclassify  

o Input Raster: sch_dist 

o Method: Equal Interval 

o Classes: 10  

 Our requirement is away so no need to reverse the values. 

o Output: Recl_sch_dist 

 

View and explore the Recl_sch_dist layer properties, legend etc 
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Weightage of influence 

 

For finding the required site each condition is having different weightage an is given below 

Distance from recreation sites : 50% 

Distance from school 25% 

For Plain terrain 13%  

For the suitable landuse 12% 

 

Weighted Overlay 

Open ArctoolBox -> Spatial Analyst tools-> Overlay -> Weighted Overlay 

 First set Evaluation Scale: From 1 to 10 by 1 

 Using Add option, add Reclass_slope, Reclrec_dist, Recl_sch_dist and landuse. 

 Reclass of slope values from 1 to 3 restricted 

 For landuse set the values as below 

o Brushland: 5 

o Barrenland: 10 

o Built up: 9 

o Agriculture: 3 

o Forest: 4 

o wetlands, water areas are not suitable for building school, set them as restricted. 

 Set influence as 

o 50 for recreation sites 

o 25 for school 

o 13 for slope 

o 12 for landuse 

 Output: weighted.tif 

 

View and explore the weighted.tif layer properties, legend etc 

 

Selecting the maximum value data from weighted overlay (ie.9) 

 

Conditional  

 Open ArctoolBox -> Spatial Analyst tools-> Conditional->Con tool 

 Input: weighted 

 Value: 9 

 Output: con-weighted.tif 

 

View and explore the con-weighted.tif layer properties, legend etc 

 

Majority filter 

To get a contiguous area we run this tool 

Open ArctoolBox -> Spatial Analyst tools-> Generalisation->Majority tool 

 Input: con-weighted.tif 

 Output: majority 

 Number of neighbors to use : Eight 

 Replacement threshold :Majority 

 

View and explore the majority layer properties, legend etc 
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Using ArcCatalog, Create a geodatabse on your folder name it result.gdb 

 

Convert raster to vactor 

Open ArctoolBox ->Conversion tool-> From raster -> Raster to polygon 

 Input: majority 

 Field: value 

 Output: majority_vec (save on result.gdb) 

 

Road connectivity 

Add road layer to Arcmap 

 

Open from menu selection->selection by location 

Method                    : Select feature from 

Target layer             : majority_vec 

Source layer            :roads 

Spatial selection method for target layer features : intersect the source layer features 

 

Few polygons from majority_vec layer get selected that have connectivity with roads 

 

Choose area abovet 10 acre 

 

Right click on majority_vec layer and open attribute table 

Open Option->select by attribute 

Method : select by current selection 

Condition : shape_area > 40469 

 

Create layer 

Right click on majority_vec->slection->create layer from selection 

 

Save the layer as data 

Open ArctoolBox ->Data management tools ->Features->Copy features tool 

Input: Majority_vec_selection 

Output: final_site (save on result.gdb) 

 

Note the area of the final site 

 

 Prepare a simple layout and export as jpeg file 

 

 

 

 

 

 

 

 

 

 

 



12 
 

Ex. No. 

4 

Raster Analysis (Least Cost Path) Date  

 

Aim: 

To understand the least cast path analysis on raster data 

 

Problem definition  

Identify a route which is least cost path from recreation site Town land to Moscow field. 

Software Used: 

ArcMap 10.2.2 

Procedure: 

o Create a folder EX4 under your roll number folder. 

o Create a ws and scratch folders under "EX4"  

o Open the ArcMap software 

o Add data from spatial93 folder (Landuse, Elevation and recreation sites ). 

o Create a geodatabase  in your folder “result.gdb” 

o Set the environment settings:  

o Workspace folder for current & scratch for scratch ws, Extent same as Landuse 

o settings Cell size: Same as the elevation 

 

 

Slope 

Open ArctoolBox -> SpatialAnalyst tools->Surface->Slope  

Input raster        :elevation 

Output raster      :slope_elev 

Measurment       :degree 

Zfactor                :0.3048         ;(ft to m) 

 

View and explore slope_elev layer properties, legend etc 

 

Reclass Slope: 

 Open ArctoolBox -> Spatial Analyst tools-> Reclassify -> Reclassify  

o Input Raster: slope_elev 

o Method: equal interval 

o Classes: 10  

 (our requirement is plain terrain, in slope analysis first group, i.e. 0-5° 

belongs to plain terrain, so we can fix it at 1 (plain terrain = 1).  and steep 

terrain 10. So  no change in new values. 

o Output Raster: Reclass_slope 

View and explore Reclass_slope layer properties, legend etc 

 

 

Weighted Overlay 

Open ArctoolBox -> Spatial Analyst tools-> Overlay -> Weighted Overlay 

 First set Evaluation Scale: From 1 to 10 by 1 

 Using Add option, add reclass of slope and landuse  

 Set equal influence (ie.50%) 

 For landuse set the values as below 

o Brushland: 5 

o Water: 10 
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o Barrenland: 2 

o Built up: 9 

o Agriculture: 4 

o Forest: 8 

o Wetlands:10 

 Output: cost 

 

View and explore the cost layer properties, legend etc 

 

 Using selection tool select Mascow field rec site 

 

Cost Distance 

Open ArctoolBox -> Spatial Analyst tools-> Distance -> Cost distance 

 Input vector: rec_sites 

 Cost raster: cost 

 Output: cost_distance  

 Output Back Link : backlink 

 

View and explore the cost_distance, backlink layers properties, legend etc 

 

 Using selection tool select Town Land rec site 

 

Cost Path 

Open ArctoolBox -> Spatial Analyst tools-> Distance ->Cost path 

 Input vector: rec_sites 

 Cost distancer: cost_distance 

 Back linkt: backlink  

 Output raster : cost_path 

 

View and explore the cost_path layer properties, legend etc 

 

Convert raster to vactor 

Open ArctoolBox ->Conversion tool-> From raster -> Raster to polyline 

 Input: cost_path 

 Output: path (save on result.gdb) 

 

Unsplit line 

Open ArctoolBox ->Data management tools ->Features->Unsplit line 

 Input: path  

 Output: final_path (save on result.gdb) 

 

Note the length of the final_path 

 

 Prepare a simple layout and export as jpeg file 
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Ex. No. 

5 

Raster Analysis (Watershed and Basin) Date  

 

Aim: 

To perform watershed delineation for the given raster data using hydrology tools from Spatial analysis 

tool. 

Software Used: ArcMap version 10.2.2 

Theory: 

 The hydrology tools are used to model the flow of water across a surface. They can be 

applied individually or used in sequence to create a stream network or delineate watersheds.    

Fill: 

o Fills sinks in a surface raster to remove small imperfections in the data. They can also 

be used to remove peaks. 

Flow Directions: 

o Flow direction creates a raster of flow direction from each cell to its steepest 

Flow Accumulation: 

 Flow accumulation creates a raster of accumulated flow into each cell. A weight factor can 

optionally be applied.    

 The result of flow accumulation is a raster of accumulated flow to each cell, as determined by 

accumulating the weight for all cells that flow into each downslope cell.    

 It does not honour the compression environment setting. The output raster will always be 

uncompressed. 

Snap Pour Point: 

 Snaps pour point to the cell of highest flow accumulation within a specified distance. 

 It is used to ensure the selection of points of high accumulated flow when delineating 

drainage basins using watershed tool. It will search within a snap distance around the 

specified pour point for the cell of highest accumulated flow and move the pour point to that 

location. 

 In output, original pour point locations have been snapped to locations of higher accumulated 

flow. 

Basin: 

 Basin creates a raster delineating all drainage basins. 

 The drainage basins are created within the analysis window and are delineated by locating 

pour points at the edges of analysis window as well as sinks. Then identifying contributing 

area above each pour point. This results in raster of drainage basins. 

 All cells in raster will belong to a basin, even if that basin is only one cell. 

Watershed: 

 Watershed determines the contributing area above a set of cells in a raster. The value of each 

watershed will be taken from a raster dataset. When pour point is used, the values will come 

from the specified field. 

Procedure 

o Create a folder EX5 under your roll number folder. 

o Create a ws and scratch folders under "EX5"  

o Open the ArcMap software 

o Add data from spatial93 folder (Elevation). 

o Create a geodatabase  in your folder “result.gdb” 

o Set the environment settings:  

o Workspace folder for current & scratch for scratch ws, Extent same as Landuse 

o settings Cell size: Same as the elevation 
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Fill: 

Open  ArcToolbox -> Spatial Analyst tool -> Hydrology -> Fill 

 Input raster: elevation 

 Output raster : fill_ras 

 (Z-limit - not needed ) 

 

View and explore the fill_ras layer properties, legend, changing symbology  etc 

 

Flow Direction: 

Open Arc Tool Box -> Spatial Analysis Tools -> Hydrology -> Flow Direction. 

 Input raster: fill_ras 

 Output raster : flowdir 

 

View and explore the flowdir layer properties, legend, changing symbology  etc 

 

Flow Accumulation: 

Open Arc Tool Box -> Spatial Analyst tool -> Hydrology -> Flow Accumulation. 

 Input raster: flowdir 

 Output raster : flowacc 

 Data type : Float 

 

Right click on 'flowacc' -> Properties -> Symbology -> Stretched -> Stretch type - Histogram 

equalization -> Apply -> okay. (Select required colours) 

 

View and explore the flowacc layer properties, legend, changing symbology  etc 

 

Pour Point: 

 Using ArcCatalog create a point feature class name as 'pourpoint'  under result.gdb 

 Create a point feature on pourpoint layer using editing tools at a required location along 

the stream end on flowacc  

 

Snap Pour Point: 

Open  Arc Tool Box -> Spatial Analysis tool -> Hydrology -> Snap pourpoint tool. 

 Input raster/vector: pourpoint  

 Pour point filed : Object ID 

 Input accumulation layer:flowacc 

 Output raster : snappour_pt 

 Sanp distance: 100  

 

Watershed: 

Open Arc Tool Box -> Spatial Analyst tool -> Hydrology -> Watershed. 

 Input flow direction raster:  flowdir 

 Input feature pour point raster: snappour_pt 

 Pour point field : value 

 Output raster : watershed 
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Raster To Polygon Conversion: 

Open Arc Tool Box -> Conversion Tools -> From Raster -> Raster to Polygon 

 Input raster: watershed 

 Field : value 

 Output: watershed (on result.gdb) 

 check of simplify polygon 

 

Extraction: 

Extracting the elevation data for watershed area and may be used for layout preparation 

 

Open Spatial Analysis tool -> Extraction -> Extract by Mask  

 Input raster: elevation 

 Feature mask: watershed (on result.gdb) 

 Output raster: clip_elevation 

 

Basin: 

Open Spatial Analysis tool -> Spatial analyst tool -> Hydrology -> Basin 

 In flow direction raster: flowdir 

 Output raster: basin 

 

Raster To Vector Conversion: 

Open Arc Tool Box -> Conversion Tools -> From Raster -> Raster to Polygon 

 Input raster: basin 

 Field : value 

 Output: basin_vec (on result.gdb) 

 check of simplify polygon 

 

Using selection tool select the biggest polygon on basin_vec save it as separate layer as basin_clip on 

result_gdb 

(Recall the tools used for such task) 

 

Extracting Flow accumulation separately. 

 

Calculation Of "Flowacc > 100": 

Open Arc Tool Box -> Spatial Analyst Tools -> Map Algebra -> Raster Calculator 

 Input layer : flowacc 

 Enter the expression: :  : Flowacc > 100 

 Output file name : flowacc_100 

 

Convert the floacc_100 to vector and save it as flowacc100_vec on result.gdb 

 

 Prepare a layout  watershed (result.gdb), clip_elevation and flowacc100_vec  

 Prepare a layout  basin_clip, clip_elevation and flowacc100_vec  
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Ex. No. 

6 

Surface Analysis (Interpolation, Contour) Date  

 
Aim: 

To perform surface analysis with various interpolation techniques. 

Software Used: 

ArcMap 10.2.2 

Procedure 

o Create a folder EX6 under your roll number folder. 

o Create a ws and scratch folders under "EX6"  

o Copy the DIND_block gdb file from share and paste it in ws folder 

o Open the ArcMap software 

o Add point data from copied file 

o Create new File Geo DB interpolation.gdb on ws folder 

o Set the Environment:  

o Extent: same as layer points 

o Cell size: 30 

o Enable extension 3D Analysis and  open Tool Bar  

IDW 

Open Arc Tool Box -> 3D Analyst Tools -> Raster interpolation -> IDW tool 

o Input point feature : points 

o z value : height  

o Cell size: 30 

o Output raster: idw-point (scratch folder) 

 

View and explore the idw-point layer properties, legend etc 

 

Contour  

Create contour using idw-point 

Open Arc Tool Box -> 3D Analyst Tools -> Raster Surface -> contour tool 

o Input raster: idw-pont (scratch folder) 

o z factor : 0.3048  

o Base  contour: (example value:611.0) 

o Contour interval: 2 

o Output raster: idw-contour (interpolation.gdb) 

 

View and explore the idw-contour layer properties, legend etc 

 Prepare a simple layout and export as jpeg file 

 

KRIGING: 

Open Arc Tool Box -> 3D Analyst Tools -> Raster interpolation -> kriging 

 

o Input point feature : points 

o z value : height  

o Cell size: 30 

o Output raster: kriging -point (scratch folder) 

o Choose ordinary  (also try other methods) 
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Contour  

Create contour using kriging –point and save as kriging-contour (interpolation.gdb) 

 

View and explore the kriging-contour layer properties, legend etc 

 Prepare a simple layout and export as jpeg file 

 

NATURAL NEIGHBOUR 

Open Arc Tool Box -> 3D Analyst Tools -> Raster interpolation -> Natural neighbour tool 

 

o Input point feature : points 

o z value : height  

o Cell size: 30 

o Output raster: nn -point (scratch folder) 

Contour  

Create contour using nn –point and save as nn-contour (interpolation.gdb) 

 

View and explore the nn-contour layer properties, legend etc 

• Prepare a simple layout and export as jpeg file 

 

SPLINE: 

Open Arc Tool Box -> 3D Analyst Tools -> Raster interpolation -> Spline tool 

 

o Input point feature : points 

o z value : height  

o Cell size: 30 

o Output raster: spline -point (scratch folder) 

Contour  

Create contour using spline –point and save as spline-contour (interpolation.gdb) 

 

View and explore the spline-contour layer properties, legend etc 

• Prepare a simple layout and export as jpeg file 
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Ex. No. 

7 

Vector Analysis (Attribute Analysis and Data 

Extraction) 

Date  

 

Aim: 

To perform vector analysis (attribute analysis) on data - attributes. 

Software: 

 ArcMap 10.2.2 

Procedure: 

o Create a folder EX7 under your roll number folder. 

o Copy the DIND_block gdb filefrom share and paste it in EX7 folder 

o Open the ArcMap software 

o Add all layers from DIND_block 

1. Select by Attributes 

Query: Show me all the village blocks having area more than 100 sq.m 

 Right click village layer ->Open attribute table.  

 Table option -> select by attribute 

o Method: create a new selection 

o Expression  : Shape: area > 1000  
o Check the expression by clicking ‘verfy’ 

o If no error Apply 

o Note number of records get selected 
 

2. Create layer from selection 

 Right click village layer ->Selection -> Create layer from the selected feature 

 

3. Export data 

 Right click selected  layer ->Data -> Export data 

 Save in Ex7 folder as shape file  

 

Do the steps 1 to 3 for the other selection methods in step 1 (given below) by forming your own 

meaning full queries. 

 

 Add to the current selection 

 Remove from the current selection 

 Select from the current selection 

 Switch selection (invert) 

 

Location Selection 
Query: How many villages have road facility? 

 

Open menu Selection -> Select by location  

o Selection Method : select features from 

o Target Layer: Village 

o Source Layer : Roads 

o Spatial selection method for target feature layer: intersect 

o Note no of records get selected 

 

In above you can apply different combination of selection method and spatial selection methods 

Save the results as shape file in EX7 as you did in previous attribute selection. 
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Ex. No. 

8 

Vector Analysis (Buffer, Union and Analysis) Date  

 

Aim: 

To perform Buffer, Union and statistical analysis 

 

Problem: 

Find out the required data and present it in the following form, towards acquiring the land by widening 

each panchayat road at 300 units on both sides with the given LANDUSE and ROAD feature classes.  

 

Procedure: 

o Create a folder EX8 under your roll number folder. 

o Copy layer ANA1020.gdb to EX8 folder 

o Open the ArcMap software 

o Add road, landuse layers from THIRU dataset 

 

Road Buffer 

Adding buf attribut 

o Open attribute table of road layer 

o Add field 

o  Name: buf,  

o Type :Short int 

o Using select by attribute select roadtype = ‘P.Road’ 

o Using Field calculator assign buf=300 

o Do switch selection 

o Using Field calculator assign buf=0 

o Do clear selection (very important)  

 

Buffer: 

Open Arc Tool Box ->Analysis->Proximity->Buffer tool 

o Input point feature : road 

o Output feature: roadbuf_300 (save in THIRU dataset) 

o Field: buf 

o Side type: FULL 

o End type: ROUND 

o Dissolve type: NONE 

 

View and explore the roadbuf_300 layer properties, legend etc 

 

Overlay-Union: 

Open Arc Tool Box ->Analysis->Overlay->Union tool 

o Input feature : landuse, roadbuff_300 

o Output feature: union (save in THIRU dataset) 

o XY tolerance: 0.001 

 

View and explore the union layer properties, legend etc 
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Adding HA, cost  fields: 

 Open attribute table of union  layer 

 Add field 

o Name: HA  

o Type : flost 

 Add field 

o Name: cost  

o Type : flost 

 Using Field calculator assign HA=(Shape_Area/10000) 

 Using Field calculator assign cost=(ACQCOST*HA) 

Selecting buffer area 

 Open union attribute table (if not open yet) 

 Using select by attribute select FID_roadbuff_300 <> -1 (Negative means outside the 

buffer area) 

 

Statistical analysis: 

Open Arc Tool Box ->Analysis->Statistics->Summery statistics tool 

o Input table : union 

o Output table: stat1(save in ANA1020.gdb) 

o Statistic filed           Statistic type 

HA                            SUM 

Cost                           SUM 

o Case Field: roadname 

o Do clear selection (very important)  

 

Join the union table and stat table get the buffer 

 Right click on union layer  -> Join and relates 

o Choose field in this layer that join will be based on: ROADNAME 

o Choose table to join to this layer: stat1 

o Choose field in table to base join on: ROADNAME 

 

Now in union attribute table have stat1 data also. To find minimum cost, using select by attribute 

on union table with the expression ‘STAT1,SUM_COST=(SELECT MIN(SUM_COST) FROM 

STAT1) 

 

 On union layer create layer from selected feature, and save it as feature class name 

‘union_selection’ under THIRU dataset. 

 

Open Arc Tool Box ->Analysis->Statistics->Summery statistics tool 

o Input table : union_selection 

o Output table: stat2(save in ANA1020.gdb) 

o Statistic filed           Statistic type 

                                  Union_HA                    SUM 

                                  Union_Cost                   SUM 

o Case Field: UnionName 
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Identifying the road that need least cost by using select by location 

 

Open menu Selection -> Select by location  

o Selection Method : select features from 

o Target Layer: Road 

o Source Layer : union_selection 

o Spatial selection method for target feature layer: have their centroid in source 

layer feature 

 

On road layer create layer from selected feature, and save it as feature class name 

‘selected_road’ under THIRU dataset. 

 

 Prepare a simple layout and export as jpeg file 

 

Fill the details as in the table 

 
Road and land  details 

Road ID Road Name 

 

Length Total area to be acquired 

in ha 

Total cost 

     

     

     

     

     

     

     

 

Suggested road and the landuse details 

Road ID Road Name Length 

   

Landuse type Area in ha Cost 

   

   

   

   

   

Total   
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Ex. No. 

9 

Vector Analysis (Erase and Identify) Date  

 
Aim: 

To perform Buffer,Eerase, Identity and statistical analysis 

 

Problem: 

Identify the suitable aquaculture site satisfying the following criteria: 

 Preferred Landuse is barren land 

 Choose the SUIT  is greater than or equal to 2  

 Site must be within  300 m of existing sewer lines 

 Site must be beyond 30 m of streams 

 Site must contain  an area of at least 1000 meters square 

 Report the area in ha. 

Procedure: 

o Create a folder EX9 under your roll number folder. 

o Copy layer ANA1020.gdb to EX9 folder 

o Open the ArcMap software 

o Add landuse, soil, sewers and streams layers from AQUA dataset 

 Explore attribute table of all layers and find the required fields to meet the criteria. 

 

 

Buffer on sewers layer (to meet within condition): 

Open Arc Tool Box ->Analysis->Proximity->Buffer tool 

o Input point feature : sewers 

o Output feature: sewbuf_300 (save in AQUA dataset) 

o Linear unit : 300 

o Side type: FULL 

o End type: ROUND 

o Dissolve type: ALL     (IMPORTANT) 

 

Buffer on streams layer (to meet away condition): 

Open Arc Tool Box ->Analysis->Proximity->Buffer tool 

o Input point feature : streams 

o Output feature: strbuf_30 (save in AQUA dataset) 

o Linear unit : 30 

o Side type: FULL 

o End type: ROUND 

o Dissolve type: ALL     (IMPORTANT) 

 

Erase (to get both away and within criteria) 

Open Arc Tool Box ->Analysis->Overlay->Erase tool  

o Input feature: sewbuf_300  

o Erase Feature: strbuf_30 

o Tolerance: 0.001 

o Output: erase (save in AQUA dataset) 

Identity-1: (spatial overlay landuse and soil to keep landuse extent) 

Open Arc Tool Box ->Analysis->Overlay->Identity tool 

o Input feature: landuse  

o Identity Feature: soil 
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o Tolerance: 0.001 

o Output: identity1 (save in AQUA dataset) 

 

Identity-2: (spatial overlay landuse and soil to keep landuse extent) 

Open Arc Tool Box ->Analysis->Overlay->Identity tool 

o Input feature: identity1  

o Identity Feature: erase 

o Tolerance: 0.001 

o Output: identity2 (save in AQUA dataset) 

 

Open attribute table of indetity2 layer 

 Add two fields  

o Name : HA, type : float 

o Name: cost, type float 

 Use field calculator to calculate 

o HA=Shape_area/1000 

o Cost=ACQCOST*HA 

 Table option -> select by attribute 

o Enter the sql: LUSENAME=’BARREN’ AND SUIT >= 2 AND FID_ERASE <> -1 

AND SHAPE_AREA >=1000; 

 

Summary statistics: 

Open Arc Tool Box ->Analysis->Statistics->Summery statistics tool 

o Input table identiy2 

o Output table: aqua_stat(save in ANA1020.gdb) 

o Statistic filed           Statistic type 

                                  Union_HA                    SUM 

                                  Union_Cost                   SUM 

 Prepare a simple layout and export as jpeg file 
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Ex. No. 

10 

Vector Analysis (Ranking, Suitability Index, 

Eliminate and Dissolve) 

Date  

 
Aim: 

To perform Ranking, Suitability Index, Eliminate, Dissolve and statistical analysis 

 

Problem: 

Identify the suitable area for growing mulberry crop with the following feature classes: 

Soil, Landuse, and Geomor. 

 

Look out the criteria listed below 

 WEIGHTAGE*: 

o Soil: 40% 

o Landuse: 40% 

o Geomor: 20% 

Rank Table 

RANK SOIL LANDUSE GEOMOR 

1. - 50  700 177 

2. 109       110 190       729 180       190 

3. 105  106  107  108 705 168     169 

4. 101  102   103   104 703     718 170 

* Consider the polygons having area >1000 Sq.m 

 Group the resultant polygons area as: 

o Highly suitable: > mean CSI + 1 SD 

o Moderately suitable: mean CSI + 1 SD - mean CSI 

o Marginally suitable: mean CSI - 1 SD - mean CSI - 1 SD 

o Poorly suitable: < mean CSI - 1 SD 

Furnish statistics such as Max CSI, Min CSI, mean, SD 

Report the area in ha. under each suitability class. 
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Procedure 

o Create a folder EX10 under your roll number folder. 

o Copy layer ANA1020.gdb to EX10 folder 

o Open the ArcMap software 

o Add landuse, soil and geomor layers from MULB dataset 

o Explore attribute table of all layers and find the required fields to meet the criteria 

 

Landuse 

 Add field ‘lrank’, short int type 

 Do select by attribute with query expression as per the data given for rank1 in the table 

o LU_CODE = 50 OR LU_CODE = 700 

o Note the number of  records get selected 

 Do filed calculator 

o lrank=1 

 Do it for other ranks in landuse layer  

 Check for all records having rank value 

 

Soil 

 Add field ‘srank’, short int type 

 Do select by attribute with query expression as per the data given for rank2 in the table 

o SOIL_CODE = 109 OR SOIL_CODE = 110 

o Note the number of  records get selected 

 Do filed calculator 

o srank=2 

 Do it for other ranks in soil layer  

 Check for all records having rank value 

 

Geomor 

Add field ‘grank’, short int type 

 Do select by attribute with query expression as per the data given for rank1 in the table 

o GEOMOR_CODE = 177 

o Note the number of  records get selected 

 Do filed calculator 

o grank=1 

 Do it for other ranks in geomor layer  

 Check for all records having rank value 

 

 

Do selection ->clear selection from main menu (it is very important) 

 

Overlay-Union: 

Open Arc Tool Box ->Analysis->Overlay->Union tool 

o Input t feature : ladnuse, soil, geomor 

o Output feature: union (save in MULB dataset) 

o XY tolerance: 0.001 

 

Note number of records in union table 

View and explore the union layer properties, legend etc 
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Use polygons having area >1000 Sq.m: 

 

Selection: 

 Do select by attribute on union layer with expression “Shape_area < =1000” 

 If any such polygons are available merge them with neighbouring polygon with the largest 

area using Eliminate tool 

 

Eliminate: 

Open Arc Tool Box ->Data Management -> Generalisation ->Eliminate tool 

o Input feature: union 

o Output feature: eliminate_1 (save in MULB dataset) 

o Uncheck the check box : The selected polygon will be merged with the neighbouring 

polygon with the longest shared border. 

 

Selection: 

 Do select by attribute on eliminate1 layer with expression “Shape_area < =1000” 

 If any such polygons are available merge them with neighbouring polygon with the largest 

area using Eliminate tool 

 

Eliminate: 

Open Arc Tool Box ->Data Management -> Generalisation ->Eliminate tool 

o Input feature: eliminate1 

o Output feature: eliminate_2 (save in MULB dataset) 

o Uncheck the check box : The selected polygon will be merged with the neighbouring 

polygon with the longest shared border. 

 

Repeat the above selection and eliminate steps till the selection result become zero. Let us assume the 

finale eliminate output layer is eliminate_n.  

 

Select clear selection from selection menu (important) 

 

Add fileds csi, ha, suitable and calculate values 

Open attribute table of eliminate_n layer 

 Add two fields  

o Name : HA, type : float 

o Name: csi,, type float 

o Name: suitable, type: short int 

 Use field calculator to calculate 

o HA=Shape_area/1000 

o csi=(lrank*0.4)+(srank*0.4)+(grank*0.2) 

o Right click on csi field choose statistics  

o Note min, max, mean, std.div (for ex. Mean 3.23, SD 0.44) 

 

Here boundary points are (3.23 - 0.44), 3.23, (3.23+0.44) which are 2.79, 3.23, 3.67 
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Suitability: 

Do select by attribute on eliminate_n layer with expression given for each class and using filed 

calculator  assign values to suitable field accordingly 

 

 High: 

o Query expression: CSI > 3.67 

o suitable = 1 

 Moderate: 

o Query: CSI > 3.23 AND CSI <= 3.67 

o suitable = 2 

 Marginal: 

o Query: CSI > 2.79 AND CSI <= 3.23 

o suitable = 3 

 Poor: 

o Query: CSI <= 2.79 

o suitable  = 4 

 

Select clear selection from selection menu (important) 

 

Summary statistics: 

Open Arc Tool Box ->Analysis->Statistics->Summery statistics tool 

o Input table: union 

o Output table: mulb_stat(save in ANA1020.gdb) 

o Statistic filed           Statistic type 

                                  HA                          SUM 

o Case field: suitable 

 

Set symbology on union layer based on suitable field with no outline. This can be used for layout. 

 

Dissolve: 

Open Arc Tool Box ->Data Management -> Generalisation ->Dissolve tool 

o Input feature: eliminate_n 

o Output feature: dissolve (save in MULB dataset) 

o Dissolve field: suitable 

Open attribute table of dissolve layer add a text type filed size 15 called ‘suitability’ and enter 

description as below according to suitable 

suitable suitability 

1 High 

2 Moderate 

3 Marginal 

4 poor 

 

 Prepare a simple layout using dissolve layer and export as jpeg file 

 

 

 

 

 



29 
 

Ex. No. 

11 

Network Analysis (Geocoding) Date  

Aim: To perform geocoding process for the given data 

Software Used: ArcMap 10.2.2 

Procedure: 

o Create a folder EX11 under your roll number folder. 

o Copy layer CHE_ROADS10.gdb to EX11 folder 

o Open the ArcMap software 

o Add selected_roads layer from ROADS dataset , change symbol “Arrow at end” so we 

know the direction 

o Explore attribute table of layer. 

 

 Add field to selected_roads 

o Name:  ‘streetname’ 

o Type: text 

o Size: 30  

 Using field calculator do streetname = roadname  (ie copy) 

 Modify the values in streetname like ST to Street, RD tor Road, remove alternative names if 

any 

 Add short int type fields namely LF_ADD, LT_ADD, RF_ADD and RT_ADD to the 

selected_roads table. (Used to store door number left side starting, left side ending, right side 

starting and right side ending.) 

 We assume odd numbers on left side and even numbers on right side and also assume 100 

houses total per street name irrespective of number of segments of the street.  

 Populate the door numbers as per the assumptions along the direction of the road 

 

Standardization 

Open Arc Tool Box ->Geocoding->Standardization tool 

o Input feature: selected_roads 

o Input address fields: Object_ID, streetname 

o Address locator style: US Streets 

o Output address fields: select all except House No 

o Output feature : Std_Roads (in ROADS dataset) 

 

 Open attribute table of Std_Roads and using field calculator do ID = Object_ID (ie copy) 

 

Creating address locator 

 Open ArcCatalog 

 Right click on ROADS dataset -> New -> Address Locator 

o Address Locator style: US Streets 

o Reference Data: Std_Roads 

o House from left: LF_ADD 

o House to left: LT_ADD 

o House from right:RF_ADD 

o House to right:RT_ADD 

o Ouput Locator name: 123_add_locator (use your rollnumber) 

 

Geocoding properties: 

 Right click 123_add_locaator -> Properties->Geocoding options 

o Match with  no zones: yes 
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Find an address: 

 Close ArcCatalog and open ArcMap 

 Add Std_roads data 

 Add label and change symbol as Arrow at end 

 Click find  button,  choose Locations tab 

 Choose locator and give 123_add_locator 

 Street or intersection: enter an address and click find. The matching addresses are 

listed below. Right click on the result choose flash o locate on the map, also explore other 

options  

 

Alternative Name to street: 

Close ArcMap and open ArcCatalog 

Right click on CHE_ROADS10.gdb -> New Table 

 Name:ALT_NAME 

 Add following fields with data type 

o JoinID, Long Integer 

o PreDir, Text, Size 12 

o PreType, Text, Size 40 

o StreetName, Text, Size 60 

o SufType, Text, Size 40 

o SufDir, Text, Size 12 

 

Place Name: 

Right click on CHE_ROADS10.gdb -> New Table 

 Name:PLACE 

 Add following fields with data type 

o Name, Text, Size 15 

o Address, Text, Size 25 

 

Preparing tables for  alternative street name and  place name : 

 Close ArcCatalog and open ArcMap 

 Add Std_roads layer, ALT_NAME, PLACE tables 

 Add label and change symbol as Arrow at end on Std_roads 

 Click Start Editing on editor toolbar 

 Using identify tool  note the ID of the street for which you need alternative name by 

clicking on the road  

 Open ALT_NAME table, enter JoinID with the noted ID value, also fill StreetName with 

alternative name and fill other fields values if you have. 

 Click Editor -> save edits 

 Open PLACE table enter place name and address (one or more) 

 Click Editor -> save edits and then Stop Editing 

 Close ArcMap 

 

Creating alternative and place address locator 

 Open ArcCatalog 

 Right click on ROADS dataset -> New -> Address Locator 

o Address Locator style: US Streets with alternate name 

o Reference Data: 

 Primary Table:  Std_Roads 
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 Alternative Table: ALT_NAME 

 Alias Table: PLACE 

o Primary Table House from left: Std_Roads : LF_ADD 

o Primary Table House to left: Std_Roads :LT_ADD 

o Primary Table House from right: Std_Roads :RF_ADD 

o Primary Table House to right: Std_Roads :RT_ADD 

o Primary Table JoinID : ID 

o Alternate Table JoinID: JoinID 

o Alias table Alias : PLACE:Name 

o Alias table Street :PLACE:Address 

o Ouput Locator name: 123Alt_add_locator (use your rollnumber) 

 

Geocoding properties: 

 Right click 123_add_locaator -> Properties->Geocoding options 

o Match with  no zones: yes 

 

Find an address with alternative street name or place name : 

 Close ArcCatalog and open ArcMap 

 Add Std_roads data 

 Add label and change symbol as Arrow at end 

 Click find  button,  choose Locations tab 

 Choose locator and give 123Alt_add_locator 

 Street or intersection: enter an address or a place to locate and click find 

 

Customer Table 

 

Close ArcMap and open ArcCatalog 

Right click on CHE_ROADS10.gdb -> New Table 

 Name:Customer 

 Add following fields with data type 

o ID, Long Integer 

o Name, Text, Size 15 

o Address, Text, Size 30 

 Close ArcCatalog and open ArcMap  

 Add Customer table  

 Editor->Start editing 

 Populate some records on Customer table 

 

Address Geocoding from table 

 Open ArcMap if not in open 

 Add Std_roads layer, Customer table 

 Right click Customer table -> Geocode Addresses 

 Choose address locator:  123Alt_add_locator 

 Address table : Customer 

 Street/Intersection: Address 

 Output layer name: Geocoding_result.shp (EX11 folder) 

 Click OK 

 If any Unmatched results are there click Rematch, in the next window match manually nearest 

one by edit/find the address 
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Ex. No. 

12 

Network Analysis Route Analysis) Date  

Aim: To perform the route analysis using ArcMap 10.2.2 

 

Procedure: 

o Copy folder EX11 and paste then rename as EX12 under your roll number folder. 

o Open the ArcMap software 

o Enable Network Analyst Extension. 

o Add std_roads layer from ROADS dataset , change symbol “Arrow at end” so we know 

the direction 

 

Adding required fields 

 

 Add field to std_roads 

o Name:  Meters  

o Type: double 

 Using field calculator do Meters = Shape_length  (ie copy) 

 Add field to std_roads 

o Name:  Speed 

o Type: Short integer 

 Add field to std_roads 

o Name:  M_P_M  

o Type: double 

 Add field to std_roads 

o Name:  Minutes 

o Type: double 

 Add field to std_roads 

o Name:  Oneway 

o Type: Text 

o Size: 2 

 Populate Speed field with value 10 if the Shape_length less than 600 else with value 20. Use 

Select by attribute and field calculator 

 Using field calculator do M_P_M = Speed*16.667 

 Using field calculator do Minutes = Meters / M_P_M 

 

 

Network dataset creation 

 Close ArcMap and open ArcCatalog 

 Right click on ROADS dataset and select New > Network Dataset 

 Type Roads_ND for the name of the network dataset, Click Next 

 Check the std_roads feature class to use it as a source for the network dataset. Click Next 

 Click Yes to model turns in the network. Click Next 

 Connectivity No change. Click Next 

 Elevation fields : None Click Next 

 The page for setting network attributes is displayed. Click next 

 Drving directions Yes. Click Next 

 Summary screen, after viewing the setting click Finish 

 Click YES to build Network dataset. After every modification the ND should be built 

 



33 
 

 

 

Network path: 

 Close ArcCatalog and open ArcMap 

 Enable Network Analyst Extension (if not yet) 

 Add Roads_ND to Arcmap 

 Click Yes to all the required layers 

 Oneway 

o Select the street segment you want restrict one way. 

o Enter either FT or TF in Onway attribute ‘for from to’ or ‘to from’ according to 

the direction of the street. 

o Click the build button to build after every modification 

                                 
 Click Network Analyst on the Network Analyst toolbar and click New Route 

 Switch to Network Analyst window and select stops. 

 Click Create new location tool  on the Network Toolbar 

 Place(min 5) stops on the street as per your requirement.  

 Use Select/Move location tool to move location if required  on the Network Toolbar 

 Analysis settings 

 Click the Analysis Layer Properties button on the Network Analyst window 

 
 Click the Analysis Settings tab. Here we set the required setting for the route, explore it 

 Leave Reorder Stops To Find Optimal Route unchecked 

 Solve 

 Click solve button  on the Network Toolbar. Now the route as per the stops is 

generated on the map 

 Click the Directions Window button  on the Network Toolbar. The Directions dialog 

box opens. Explore it, note distance and time and save this as html with map document 

 Optimum path 

 Click the Analysis Settings tab. Check the Reorder Stops To Find Optimal option and 

preserve first and last stop 

 Now again solve the route and note direction details. The system now shows the optimum 

route  by reordering the intermediate stops 

 Explore other network components like barriers, route etc. 
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Ex. No. 

13 

Network Analysis (Closest Facility, Service Area) Date  

Aim: 

To perform network analysis such as closest facility and service area. 

Software Used: 

ArcMap 10.2.2 

 

Procedure: 

o Copy folder EX12 and paste then rename as EX13 under your roll number folder. 

o Copy CHE_FAC.GDB from share folder 

o Open the ArcMap software 

o Enable Network Analyst Extension. 

o Add Road_ND layer, change symbol “Arrow at end” so we know the direction 

o Add ATMs, FIRSERV, Supply layers from FACI dataset  and change symbol for the 

layers 

 

Closest Facility: 

 Click Network Analyst on the Network Analyst toolbar and click New Closest Facility 

 Click the Analysis Layer Properties button on the Network Analyst window. 

 Open Analysis setting tab do the following settings 

o Travel from: Facility to incident 

o Cut-off: 10 

o Facilities to find: 7 

o U-Turn: Not allowed 

o Apply, OK 

 On the Network Analyst window Right click on facilities -> load location -> Choose 

FIRSERV Load From drop-down list. 

 On the Network Analyst window Right click on Incidents->Find Address 

o Choose address locator : 123Alt_add_locator 

o Intersection: 18, Prakasam Road (enter an address) and click find 

o Right click on the result location and choose  add as Network analysis object option 

 Click solve button  on the Network Toolbar. Now the route is generated on the map 

 Click the Directions Window button  on the Network Toolbar. The Directions dialog box 

opens. Explore it, note distance and time, Change units as Kilo meters and save this as html 

with map document 

 Do some changes if require on analysis settings like cut-off, facilities to find etc. and solve 

again check the results. 

 Prepare a layout and export as jpeg file 

 

Do the above steps with ATMs layer and in the setting Travel from as incident to facility 

 

Service Area: 

 Click Network Analyst on the Network Analyst toolbar and click New Service Area 

 On the Network Analyst window Right click on facilities -> load location -> Choose Supply 

Load From drop-down list. 

 Click the Analysis Layer Properties button on the Network Analyst window. 

 Open Analysis setting tab do the following settings 

o Default barrier: 3.5,10 

o Impudent :Minutes 

o Direction: Away from facility 
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o U-turn: not allowed 

o Check  Oneway and  Ignore invalid locations 

 Click the Polygon Generation tab. 

o Uncheck TrimPoly 

 Click Line generation tab 

o Leave unchecked all 

 Apply, OK 

 Under facilities keep Main,Point4 and Point5 and remove others 

 Click solve button  on the Network Toolbar. Now the service area is generated on the map 

 Explore the polygons layer properties legend and do some spatial queries with facilities  

 Do some changes if require on analysis settings like default barrier, add or change facilities 

etc. and solve again check the results. 

 Prepare a layout and export as jpeg file 
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Ex. No. 

14 

Customization (Tool Bar, Scripts, Model) Date  

Aim: To do customization, Scripting & modelling. 

Procedure: 

o Create a folder EX14 under your roll number folder. 

o Copy folder aquashp to EX14 folder 

o Open the ArcMap software 

o Add landuse layer from aquashp folder  

o Save ArcMap document as cust.mxd in EX14 folder 

 

User interface customizations: 

 Choose Customise mode from Customise menu 

 Click New and give name as MyToolBar 

 A empty toolbar added to ArcMap along with other toolbars  

 Switch to Commands Tab 

 Select Pan/Zoom under categories 

 Drag and drop some tools like pan, zoom, full extent etc., from commands to  MyToolBar 

 Select [Menu] under categories 

 Drag and drop some menus like File, Edit, Selection, etc., from commands to  MyToolBar 

 Close customise mode window 

 Save Map Document 

 The MyToolBar will be available when you open cust.mxd next time 

 

Scripting: 

Open a Notepad and type the following python script and save as buffer.py 

# Name: buffer.py 

# import system modules  

import arcpy 

from arcpy import env 

 

# Set environment settings 

arcpy.env.workspace = "C:/cust/aquashps" 

 

# Buffer areas of impact around major roads 

inp = "SEWERS.shp" 

outp = "b2.shp" 

dist= 100 

print inp 

print outp 

print arcpy.env.workspace 

arcpy.Buffer_analysis(inp, outp, dist,"FULL","ROUND","ALL") 

 

Open a command window 

 Type the set path command 

 set path=c:\python27\ArcGIS10.2;%path% 

 type buffer.py 

 If no error the script will create a buffer layer b2.shp 
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Adding Script to ToolBox: 

 Open ArcCatalog 

 Right Click on EX14 folder -> New ToolBox and name it as MyToolBox 

 Right click MyToolBox->Add ->script 

 Add Name, Label and Description, Click Next 

 Browse select buffer.py Click Next 

 Click Finish 

 

Adding Scripting to toolbar 

 Open cust.mxd in ArcMap 

 Choose Customise mode from Customise menu 

 Click AddTool 

 Browse to MyToolBox and add script 

 It is added under Geoprocessing Tools category 

 Drag and drop the script to MyToolBar 

 You can change the icon by right click on script on MyToolBar then Change Button image 

 Close customise mode window 

 Like any other button tool now the script can also be executed 

 

Script with Paramenters 

Open a Notepad and type the following python script and save as buffer1.py 

# Name: buffer1.py 

# import system modules  

import arcpy 

from arcpy import env 

 

# Set environment settings 

env.workspace = "C:/GEO2017/aquashps" 

 

# Buffer areas of impact around major roads 

inp = arcpy.GetParameterAsText(0) 

outp = arcpy.GetParameterAsText(1) 

dist= arcpy.GetParameter(2) 

 

arcpy.Buffer_analysis(inp, outp, dist,"FULL","ROUND","ALL") 

 

Adding Script to ToolBox: 

 Open ArcCatalog 

 Right click MyToolBox->Add ->script 

 Add Name, Label and Description, Click Next 

 Browse select buffer1.py Click Next 

 Display Name   Data Type    Direction 

 Input Layer       Shape file    Input 

Output Layer      Shape file    Output 

Distance             long int        Input 

 Click Finish 

 

Add this script also to MyToolBar in cust.mxd 
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Model Builder 

 Open ArcCatalog 

 Browse to EX14 folder 

 Right Click on MyToolBox -> New-> Model 

 On Opened Model Builder Open Model->Model Properties 

 Enter Name:MyModel, Lable:My Model, and description: Sew Buffer 

 Drag  ArcToolBox->Analysis Tools Box->Proximity Tool set-Buffer tool and drop in the 

Model builder window 

 Drag sewers layer from TOC to Model Builder 

 
 Using connect tool link sewers to buffer tool as Input feature 

 Right Click on Buffer tool->Make Variable ->From Parameter ->Distance 

 Open Distance variable and enter 300 as value 

 Click Auto Layout button 

 Save 

 Run 

 Model->Export->To Grphics.. save as Jpeg file 
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Ex. No. 

15 

WEBGIS (Demo) Date  

Aim: 

To understand the webgis concept. 

Applications: 

 Mapserver 

 Geoserver 

Procedure 

Open web browser and try following urls  

 

 http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse.mab&mode=map 

 Output is with no color 

 http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse1.mab&mode=map 

 Change in the background color 

 http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse2.mab&mode=map 

 Polygons with different colors 

 http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse3.mab&mode=map 

 Polygons with different colors and landuse lables 

 http://hp210-pc:8081/geoserver/web 

 The geoserver java based mapserver 

 

Explore the .map files in hp210 system and try with your own map to publish 

Result: 

Thus, the concept of webgis was understood by the use of MapServer Services. 

 

 

 

 

http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse.mab&mode=map
http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse1.mab&mode=map
http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse2.mab&mode=map
http://hp210-pc/cgi-bin/mapserv.exe?map=/ms4w/apps/labmaps/landuse3.mab&mode=map
http://hp210-pc:8081/geoserver/web

